نرم‌‌افزار cPanel یک مجموعه نرم‌افزاری معروف است که شرکت‌های میزبانی وب برای مدیریت وب‌سایت مشتریان خود از آن استفاده می‌کنند. محققان امنیتی اعلام کردند که اجرای احراز هویت دو عاملی روی نرم‌افزار قدیمی cPanel & WebHost Manager (WHM) در برابر حملات brute-force آسیب‌پذیر است و به مهاجمان سایبری اجازه می‌دهد پارامترهای URL را حدس و فرآیند احراز هویت دوعاملی را در صورت فعال بودن این ویژگی، دور بزنند.

در حالی‌که حملات brute-force، به‌طور کلی معمولا ساعت‌ها یا روزها طول می‌کشد، اما در باگ کشف شده جدید، این حمله فقط به چند دقیقه زمان نیاز دارد. شرکت cPanel اعلام کرده است که نرم‌افزارش در حال‌حاضر توسط صدها شرکت میزبان وب برای مدیریت بیش از ۷۰ میلیون دامنه در سراسر جهان استفاده می‌شود.‌صاحبان وب‌سایت‌ها برای دسترسی و مدیریت وب‌سایت و تنظیمات اساسی سرور، از این حساب‌ها استفاده می‌کنند، امنیت دسترسی به این حساب‌ها حیاتی است‌ زیرا به‌محض به‌خطر افتادن آنها، کنترل کامل سایت قربانی، در اختیار مهاجمان سایبری قرار می‌گیرد. پایگاه اینترنتی ZDNet نوشته است: بهره‌برداری از این نقص، همچنین مستلزم این است که مهاجمان دارای حساب کاربری معتبری برای یک حساب هدفمند باشند، اما این مورد را می‌توانند با فیشینگ روی اطلاعات صاحب وب‌سایت به‌دست آورند.

تیم cPanel وصله این نقص را منتشر کرده و نقص را در نسخه‌های ۱۱.۹۲.۰.۲، ۱۱.۹۰.۰.۱۷ و ۱۱.۸۶.۰.۳۲ در cPanel و WHM رفع کرده است. دارندگان وب‌سایتی که از احراز هویت دو عاملی در ورود به سیستم cPanel خود استفاده می‌کنند، می‌توانند با بررسی شماره نسخه سیستم‌عامل، وضعیت به‌روزرسانی cPanel خود را مشاهده کنند.

کارشناسان معاونت بررسی مرکز مدیریت راهبردی افتا می‌گویند: به‌دلیل وجود این نقص امنیتی، کاربران نباید احراز‌هویت دو عاملی را برای حساب‌های cPanel خود غیرفعال کنند، اما در عوض باید از ارائه‌دهندگان میزبانی وب خود، درخواست کنند cPanel به آخرین نسخه به‌روز شود.

این مطلب برایم مفید است
5 نفر این پست را پسندیده اند